ADS Imaging – project catalyst

Catalyst needs us to install eight new servers for them this week. Although it will probably take longer, I have decided to take a stab at using Microsoft ADS (automated deployment services) to roll out the systems.


  1. Install ADS on server “sysimg1” (reusing the host “castor” from the NetWare days). Select “install MSDE engine locally” and “create self-signed certificate” options. Did not select PXE boot server option… will need to do this later. Also, created share “images” on the root of the c: drive” (note that local storage is rather limited… this may become an issue as time passes).
  2. Created WinPE boot CD rom with ADS support, using ADS documentation as a guide. See notes in this blog in on generating WinPE images.
  3. Created reference system:
    • install MS Office 2003 with SP1, full install from \filesmca. Ran LISTool from the office 2003 resource kit to move the installation source to the C: drive where it will be imaged properly.
    • – NOTE: did not do this on subsequent system configurations!

    • Install Networker client version 7.2.1, using “Change Journal Manger” option on all local volumes (default settings… saved installer to \filessoftwareServer Resourcesnetworker).
    • Install ActiveState ActivePERL. Latest version from (saved to \filessoftwareactive perl).
    • Install Dell OpenManage Server Administrator – v4.4, with sp1 patch (from \filessoftwareserver resourcesdell).
    • Install SSH communication Security SSH client – latest version, default settings.
    • Install 2003 server resource kit, support tools, “adminpak.msi” for 2003 with sp1.
    • Re-install Intel ProSet utility, using “modify” MSI option, then adding all components (advanced services, Intel WMI agent) – allows for NIC teaming.
    • Install GVim and Notepad++ text editors (deselect “use as default html viewer” for Notepad++).
    • Install “runtime” version of Oracle 10g client v10.2.0.1 to the “c” drive. Added tnsnames.ora file provided by catalyst staff to the %oracle_home%networkadmin directory. Per instructions from Nancy Snow, add “TNS_ADMIN” system environment variable pointing to the same directory containing the TNSNAMES.ora file.
    • add “psadm” CAMPUS directory group to local administrators group.
    • create c:sysprep directory. Add sysprep.exe, setupcl.exe from Server 2003 sp1 “” file (support tools directory on the 2003 cd). copy sample sysprep.inf file from “\sysimgc$program filesmicrosoft adssamplessysprep” directory. Add minor tweaks, copy back to source directory.
    • run chkdsk and defrag a few times for good measure.
  4. run “sysprep /reboot” on the reference system. Boot to WinPE CD.
  5. from the PE console, cd to the “tools” directory. Run:

    imgdeploy /capture /p c: d:.img “”

    Then “exit” when the image is complete.
    Note:networking still not working in PE image. Aargh! Well, I guess I will just have to upload the image manually.